In short
- CVE-2022-43718 is a MEDIUM (CVSS 5.4) vulnerability affecting apache-superset, superset (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.5% of all vulnerabilities.
- Fix: update to 2.0.1, 1.5.3 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-superset PyPI | = 2.0.0≥ 2.0.0, < 2.0.1≤ 1.5.2< 1.5.3
| 2.0.11.5.3
|
| superset | = 2.0.0≤ 1.5.2
| No fix yet |
Description
Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
NVD description
Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
More vulnerabilities in apache-superset
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free