| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.iotdb:flink-tsfile-connector | ≥ 0.12.2, < 0.13.3 | 0.13.3 |
| org.apache.iotdb:iotdb-server | ≥ 0.12.2, < 0.13.3 | 0.13.3 |
| org.apache.iotdb:tsfile | ≥ 0.12.2, < 0.13.3 | 0.13.3 |
| apache-iotdb | ≥ 0.12.2, < 0.13.3 | 0.13.3 |
| iotdb | ≥ 0.12.2, ≤ 0.12.6≥ 0.13.0, ≤ 0.13.2 |
Apache IoTDB versions 0.12.2 through 0.12.6, and 0.13.0 through 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. This issue is patched in 0.13.3. Users should upgrade or use a later version of Java to avoid it.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free