In short
- CVE-2022-43982 is a MEDIUM (CVSS 6.1) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.0% of all vulnerabilities.
- Fix: update to 2.4.2, 2.4.2rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | < 2.4.2< 2.4.2rc1
| 2.4.22.4.2rc1
|
| airflow | < 2.4.2
| 2.4.2
|
Description
In Apache Airflow versions prior to 2.4.2, the "Trigger DAG with config" screen was susceptible to XSS attacks via the origin query argument.
NVD description
In Apache Airflow versions prior to 2.4.2, the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free