In short
- CVE-2022-44310 is a HIGH (CVSS 7.5) vulnerability affecting ecdh (ecdh project), ecdh.
- Chance of exploitation in the next 30 days (EPSS): 0.67%, higher than 52.1% of all vulnerabilities.
- Fix: update to 0.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ecdh | < 0.2.0
| 0.2.0
|
| ecdh npm | < 0.2.0
| 0.2.0
|
Description
In Development IL ecdh before 0.2.0, an attacker can send an invalid point (not on the curve) as the public key, and obtain the derived shared secret.
NVD description
In Development IL ecdh before 0.2.0, an attacker can send an invalid point (not on the curve) as the public key, and obtain the derived shared secret.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free