In short
- CVE-2022-44900 is a CRITICAL (CVSS 9.1) vulnerability affecting py7zr, py7zr (py7zr project).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.4% of all vulnerabilities.
- Fix: update to 0.20.1 or later.
| Package | Affected versions | Patched versions |
|---|
| py7zr PyPI | < 0.20.1
| 0.20.1
|
| py7zr | < 0.20.1
| 0.20.1
|
Description
A directory traversal vulnerability in the SevenZipFile.extractall() function of the python library py7zr v0.20.0 and earlier allows attackers to write arbitrary files via extracting a crafted 7z file.
NVD description
A directory traversal vulnerability in the SevenZipFile.extractall() function of the python library py7zr v0.20.0 and earlier allows attackers to write arbitrary files via extracting a crafted 7z file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free