In short
- CVE-2022-45151 is a MEDIUM (CVSS 5.4) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.71%, higher than 53.6% of all vulnerabilities.
- Fix: update to 3.11.11, 4.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.11, < 3.11.11≥ 4.0, < 4.0.5
| 3.11.114.0.5
|
| moodle | ≥ 3.11.0, < 3.11.11≥ 4.0.0, < 4.0.5
| 3.11.114.0.5
|
Description
The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.
NVD description
The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free