In short
- CVE-2022-48110 is a MEDIUM (CVSS 6.1) vulnerability affecting ckeditor (ckeditor), ckeditor5.
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.7% of all vulnerabilities.
- Fix: update to 36.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ckeditor | = 35.4.0
| No fix yet |
| ckeditor5 npm | < 36.0.0
| 36.0.0
|
Description
CKSource CKEditor5 35.4.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the Full Featured CKEditor5 widget.
NOTE: the vendor's position is that this is not a vulnerability. The CKEditor 5 documentation discusses that it is the responsibility of an integrator (who is adding CKEditor 5 functionality to a website) to choose the correct security settings for their use case. Also, safe default values are established (e.g., config.htmlEmbed.showPreviews is false).
NVD description
CKSource CKEditor 5 35.4.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the Full Featured CKEditor5 widget. NOTE: the vendor's position is that this is not a vulnerability. The CKEditor 5 documentation discusses that it is the responsibility of an integrator (who is adding CKEditor 5 functionality to a website) to choose the correct security settings for their use case. Also, safe default values are established (e.g., config.htmlEmbed.showPreviews is false).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free