In short
- CVE-2023-0229 is a MEDIUM (CVSS 6.3) vulnerability affecting github.com/openshift/apiserver-library-go, openshift (redhat).
- Chance of exploitation in the next 30 days (EPSS): 0.65%, higher than 51.0% of all vulnerabilities.
- Fix: update to 0.0.0-20230119093715-30f75d79e424, 0.0.0-20230120221150-cefee9e0162b or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/openshift/apiserver-library-go Go | < 0.0.0-20230119093715-30f75d79e424< 0.0.0-20230120221150-cefee9e0162b
| 0.0.0-20230119093715-30f75d79e4240.0.0-20230120221150-cefee9e0162b
|
| openshift | = 4.11= 4.12
| No fix yet |
Description
A flaw was found in github.com/openshift/apiserver-library-go, used in OpenShift 4.12 and 4.11, that contains an issue that can allow low-privileged users to set the seccomp profile for pods they control to "unconfined." By default, the seccomp profile used in the restricted-v2 Security Context Constraint (SCC) is "runtime/default," allowing users to disable seccomp for pods they can create and modify.
NVD description
A flaw was found in github.com/openshift/apiserver-library-go, used in OpenShift 4.12 and 4.11, that contains an issue that can allow low-privileged users to set the seccomp profile for pods they control to "unconfined." By default, the seccomp profile used in the restricted-v2 Security Context Constraint (SCC) is "runtime/default," allowing users to disable seccomp for pods they can create and modify.
More vulnerabilities in github.com/openshift/apiserver-library-go
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free