In short
- CVE-2023-0872 is a HIGH (CVSS 8.0) vulnerability affecting org.opennms:opennms-webapp-rest, horizon (opennms), meridian (opennms).
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.6% of all vulnerabilities.
- Fix: update to 32.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| org.opennms:opennms-webapp-rest Maven | ≥ 31.0.8, < 32.0.2
| 32.0.2
|
| horizon | ≥ 31.0.8, < 32.0.2
| 32.0.2
|
| meridian | ≥ 2020.0.0, ≤ 2020.1.37≥ 2021.0.0, ≤ 2021.1.29≥ 2022.0.0, ≤ 2022.1.18≥ 2023.0.0, ≤ 2023.1.5
| No fix yet |
Description
The Horizon REST API includes a users endpoint in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks Erik Wynter for reporting this issue.
NVD description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
OpenNMS thanks Erik Wynter for reporting this issue.
More vulnerabilities in org.opennms:opennms-webapp-rest
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free