| Package | Affected versions | Patched versions |
|---|---|---|
| enterprise server | ≥ 3.5.0, < 3.5.12≥ 3.6.0, < 3.6.8≥ 3.7.0, < 3.7.5< 3.4.15 | 3.5.123.6.83.7.53.4.15 |
A code injection vulnerability was identified in GitHub Enterprise Server that allowed setting arbitrary environment variables from a single environment variable value in GitHub Actions when using a Windows based runner. To exploit this vulnerability, an attacker would need existing permission to control the value of environment variables for use with GitHub Actions. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.8.0 and was fixed in versions 3.4.15, 3.5.12, 3.6.8, 3.7.5. This vulnerability was reported via the GitHub Bug Bounty program.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free