In short
- CVE-2023-22626 is a HIGH (CVSS 7.5) vulnerability affecting pghero, pghero (pghero project).
- Chance of exploitation in the next 30 days (EPSS): 0.87%, higher than 59.0% of all vulnerabilities.
- Fix: update to 3.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pghero RubyGems | < 3.1.0
| 3.1.0
|
| pghero | ≥ 0.1.1, < 3.1.0
| 3.1.0
|
Description
PgHero before 3.1.0 allows Information Disclosure via EXPLAIN because query results may be present in an error message. (Depending on database user privileges, this may only be information from the database, or may be information from file contents on the database server.)
NVD description
PgHero before 3.1.0 allows Information Disclosure via EXPLAIN because query results may be present in an error message. (Depending on database user privileges, this may only be information from the database, or may be information from file contents on the database server.)
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free