In short
- CVE-2023-22728 is a MEDIUM (CVSS 4.3) vulnerability affecting silverstripe/framework, framework (silverstripe).
- Chance of exploitation in the next 30 days (EPSS): 0.49%, higher than 41.8% of all vulnerabilities.
- Fix: update to 4.12.5 or later.
Description
The GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access.
Upgrade to silverstripe/framework 4.12.5 or above to address the issue.
Reported by Stephan Bauer from relaxt Webdienstleistungsagentur GmbH
NVD description
Silverstripe Framework is the Model-View-Controller framework that powers the Silverstripe content management system. Prior to version 4.12.15, the GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access. Users should upgrade to Silverstripe Framework 4.12.15 or above to address the issue.
More vulnerabilities in silverstripe/framework
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free