| Package | Affected versions | Patched versions |
|---|---|---|
| enterprise server | = 3.8.0≥ 3.5.0, < 3.5.15≥ 3.6.0, < 3.6.11≥ 3.7.0, < 3.7.8< 3.4.18 | 3.5.153.6.113.7.83.4.18 |
An improper authentication vulnerability was identified in GitHub Enterprise Server that allowed an unauthorized actor to modify other users' secret gists by authenticating through an SSH certificate authority. To do so, a user had to know the secret gist's URL. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free