| Package | Affected versions | Patched versions |
|---|---|---|
| enterprise server | = 3.10.0≥ 3.7.0, < 3.7.15≥ 3.8.0, < 3.8.8≥ 3.9.0, < 3.9.3< 3.6.17 | 3.7.153.8.83.9.33.6.17 |
An incorrect comparison vulnerability was identified in GitHub Enterprise Server that allowed commit smuggling by displaying an incorrect diff in a re-opened Pull Request. To do so, an attacker would need write access to the repository. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in versions 3.6.17, 3.7.15, 3.8.8, 3.9.3, and 3.10.1. This vulnerability was reported via the GitHub Bug Bounty program.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free