In short
- CVE-2023-25569 is a MEDIUM (CVSS 5.7) vulnerability affecting com.ctrip.framework.apollo:apollo, apollo (apolloconfig).
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 28.9% of all vulnerabilities.
- Fix: update to 2.1.0 or later.
Description
Impact
A low-privileged user can create a special web page. If an authenticated portal admin visits this page, the page can silently send a request to assign new roles for that user without any confirmation from the Portal admin.
Patches
Cookie SameSite strategy was set to Lax in #4664 and was released in v2.1.0.
Workarounds
To fix the potential issue without upgrading, simply follow the advice that does not visit unknown source pages.
References
Apollo Security Guidence
For more information
If you have any questions or comments about this advisory:
NVD description
Apollo is a configuration management system. Prior to version 2.1.0, a low-privileged user can create a special web page. If an authenticated portal admin visits this page, the page can silently send a request to assign new roles for that user without any confirmation from the Portal admin. Cookie SameSite strategy was set to Lax in version 2.1.0. As a workaround, avoid visiting unknown source pages.
More vulnerabilities in com.ctrip.framework.apollo:apollo
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free