In short
- CVE-2023-26108 is a MEDIUM (CVSS 5.3) vulnerability affecting nest (nestjs), @nestjs/core.
- Chance of exploitation in the next 30 days (EPSS): 0.71%, higher than 53.4% of all vulnerabilities.
- Fix: update to 9.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| nest | < 9.0.5
| 9.0.5
|
| @nestjs/core npm | < 9.0.5
| 9.0.5
|
Description
Versions of the package @nestjs/core before 9.0.5 are vulnerable to Information Exposure via the StreamableFile pipe. Exploiting this vulnerability is possible when the client cancels a request while it is streaming a StreamableFile, the stream wrapped by the StreamableFile will be kept open.
NVD description
Versions of the package @nestjs/core before 9.0.5 are vulnerable to Information Exposure via the StreamableFile pipe. Exploiting this vulnerability is possible when the client cancels a request while it is streaming a StreamableFile, the stream wrapped by the StreamableFile will be kept open.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free