In short
- CVE-2023-26119 is a CRITICAL (CVSS 9.8) vulnerability affecting net.sourceforge.htmlunit:htmlunit, htmlunit (htmlunit).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.8% of all vulnerabilities.
- Fix: update to 3.0.0 or later.
Description
Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage.
NVD description
Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage.
More vulnerabilities in net.sourceforge.htmlunit:htmlunit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free