In short
- CVE-2023-26125 is a HIGH (CVSS 7.3) vulnerability affecting github.com/gin-gonic/gin, gin (gin-gonic).
- Chance of exploitation in the next 30 days (EPSS): 0.91%, higher than 60.0% of all vulnerabilities.
- Fix: update to 1.9.0 or later.
Description
Versions of the package github.com/gin-gonic/gin before version 1.9.0 are vulnerable to Improper Input Validation by allowing an attacker to use a specially crafted request via the X-Forwarded-Prefix header, potentially leading to cache poisoning.
Note: Although this issue does not pose a significant threat on its own it can serve as an input vector for other more impactful vulnerabilities. However, successful exploitation may depend on the server configuration and whether the header is used in the application logic.
NVD description
Versions of the package github.com/gin-gonic/gin before 1.9.0 are vulnerable to Improper Input Validation by allowing an attacker to use a specially crafted request via the X-Forwarded-Prefix header, potentially leading to cache poisoning.
**Note:** Although this issue does not pose a significant threat on its own it can serve as an input vector for other more impactful vulnerabilities. However, successful exploitation may depend on the server configuration and whether the header is used in the application logic.
More vulnerabilities in github.com/gin-gonic/gin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free