In short
- CVE-2023-26132 is a HIGH (CVSS 7.5) vulnerability affecting dottie (dottie project), dottie.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.6% of all vulnerabilities.
- Fix: update to 2.0.4 or later.
| Package | Affected versions | Patched versions |
|---|
| dottie | < 2.0.4
| 2.0.4
|
| dottie npm | < 2.0.4
| 2.0.4
|
Description
Versions of the package dottie before 2.0.4 are vulnerable to Prototype Pollution due to insufficient checks, via the set() function and the current variable in the /dottie.js file.
NVD description
Versions of the package dottie before 2.0.4 are vulnerable to Prototype Pollution due to insufficient checks, via the set() function and the current variable in the /dottie.js file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free