In short
- CVE-2023-26144 is a MEDIUM (CVSS 5.3) vulnerability affecting graphql (graphql), graphql.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 73.6% of all vulnerabilities.
- Fix: update to 16.8.1 or later.
| Package | Affected versions | Patched versions |
|---|
| graphql | = 17.0.0≥ 16.3.0, < 16.8.1
| 16.8.1
|
| graphql npm | ≥ 16.3.0, < 16.8.1
| 16.8.1
|
Description
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.
Note: It was not proven that this vulnerability can crash the process.
NVD description
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance.
**Note:** It was not proven that this vulnerability can crash the process.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free