In short
- CVE-2023-26470 is a HIGH (CVSS 7.5) vulnerability affecting org.xwiki.platform:xwiki-platform-oldcore, xwiki (xwiki).
- Chance of exploitation in the next 30 days (EPSS): 0.85%, higher than 58.4% of all vulnerabilities.
- Fix: update to 14.0-rc-1, 14.0 or later.
Description
Impact
It's possible to make the farm unusable by adding an object to a page with a huge number (e.g. 67108863). This will most of the time fill the memory allocated to XWiki and make it unusable every time this document is manipulated.
Patches
It has been patched in XWiki 14.0
Workarounds
There is no workaround.
References
https://jira.xwiki.org/browse/XWIKI-19223
For more information
If you have any questions or comments about this advisory:
NVD description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It's possible to make the farm unusable by adding an object to a page with a huge number (e.g. 67108863). Most of the time this will fill the memory allocated to XWiki and make it unusable every time this document is manipulated. This issue has been patched in XWiki 14.0-rc-1.
More vulnerabilities in org.xwiki.platform:xwiki-platform-oldcore
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free