In short
- CVE-2023-27475 is a HIGH (CVSS 8.8) vulnerability affecting github.com/gookit/goutil, goutil (goutil project).
- Chance of exploitation in the next 30 days (EPSS): 0.85%, higher than 58.4% of all vulnerabilities.
- Fix: update to 0.6.0, 0.6.7 or later.
Description
Impact
ZipSlip issue when use fsutil package to unzip files.
When users use fsutil.Unzip to unzip zip files from a malicious attacker, they may be vulnerable to path traversal.
Patches
It has been fixed in v0.6.0, Please upgrade version to v0.6.0 or above.
Workarounds
No, users have to upgrade version.
NVD description
Goutil is a collection of miscellaneous functionality for the go language. In versions prior to 0.6.0 when users use fsutil.Unzip to unzip zip files from a malicious attacker, they may be vulnerable to path traversal. This vulnerability is known as a ZipSlip. This issue has been fixed in version 0.6.0, users are advised to upgrade. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free