In short
- CVE-2023-27484 is a MEDIUM (CVSS 4.9) vulnerability affecting github.com/crossplane/crossplane, crossplane (crossplane).
- Chance of exploitation in the next 30 days (EPSS): 0.68%, higher than 52.3% of all vulnerabilities.
- Fix: update to 1.10.3, 1.11.2, 1.9.2 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/crossplane/crossplane Go | ≥ 1.10.0, < 1.10.3≥ 1.11.0, < 1.11.2< 1.9.2
| 1.10.31.11.21.9.2
|
| crossplane | ≥ 1.10.0, < 1.10.3≥ 1.11.0, < 1.11.2≥ 1.9.0, < 1.9.2
| 1.10.31.11.21.9.2
|
Description
Summary
Fuzz testing, by Ada Logics and sponsored by the CNCF, identified a vulnerability in the fieldpath package from crossplane/crossplane-runtime that an already highly privileged Crossplane user able to create or update Compositions could leverage to cause an out of memory panic in Crossplane.
Details
Compositions allow users to specify patches inserting elements into arrays at an arbitrary index. When a Composition is selected for a Composite Resource, patches are evaluated and if a specified index is greater than the current size of the target slice, that slice's size will be increased to the specified index, which could lead to an excessive amount of memory usage and therefore the Pod being OOM-Killed. The index is already capped to the maximum value for a uint32 (4294967295) when parsed, but that is still an unnecessarily large value.
Workaround
Users can restrict write privileges on Compositions to only admin users as a workaround.
NVD description
crossplane-runtime is a set of go libraries used to build Kubernetes controllers in Crossplane and its related stacks. In affected versions an already highly privileged user able to create or update Compositions can specify an arbitrarily high index in a patch's `ToFieldPath`, which could lead to excessive memory usage once such Composition is selected for a Composite resource. Compositions allow users to specify patches inserting elements into arrays at an arbitrary index. When a Composition is selected for a Composite Resource, patches are evaluated and if a specified index is greater than the current size of the target slice, Crossplane will grow that slice up to the specified index, which could lead to an excessive amount of memory usage and therefore the Pod being OOM-Killed. The index is already capped to the maximum value for a uint32 (4294967295) when parsed, but that is still an unnecessarily large value. This issue has been addressed in versions 1.11.2, 1.10.3, and 1.9.2. Users are advised to upgrade. Users unable to upgrade can restrict write privileges on Compositions to only admin users as a workaround.
More vulnerabilities in github.com/crossplane/crossplane
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free