In short
- CVE-2023-27524 is a CRITICAL (CVSS 9.8) vulnerability affecting apache-superset, superset (apache).
- Exploited in the wild: CISA added it to the KEV catalog on 08/01/2024.
- Chance of exploitation in the next 30 days (EPSS): 98.1%, higher than 99.9% of all vulnerabilities.
- Fix: update to 2.1.0 or later.
Description
Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config.
NVD description
Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config.
All superset installations should always set a unique secure random SECRET_KEY. Your SECRET_KEY is used to securely sign all session cookies and encrypting sensitive information on the database.
Add a strong SECRET_KEY to your `superset_config.py` file like:
SECRET_KEY = <YOUR_OWN_RANDOM_GENERATED_SECRET_KEY>
Alternatively you can set it with `SUPERSET_SECRET_KEY` environment variable.
More vulnerabilities in apache-superset
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free