In short
- CVE-2023-28102 is a CRITICAL (CVSS 9.6) vulnerability affecting discordrb, discordrb (discordrb project).
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.2% of all vulnerabilities.
- Fix: update to 3.4.3, 2023-03-08 or later.
| Package | Affected versions | Patched versions |
|---|
| discordrb RubyGems | < 3.4.3
| 3.4.3
|
| discordrb | < 2023-03-08
| 2023-03-08
|
Description
discordrb is an implementation of the Discord API using Ruby. In discordrb before commit 91e13043ffa the encoder.rb file unsafely constructs a shell string using the file parameter, which can potentially leave clients of discordrb vulnerable to command injection. The library is not directly exploitable: the exploit requires that some client of the library calls the vulnerable method with user input. However, if unsafe input reaches the library method, then an attacker can execute arbitrary shell commands on the host machine. Full impact will depend on the permissions of the process running the discordrb library and will likely not be total system access. This issue has been addressed in code, but a new release of the discordrb gem has not been uploaded to rubygems. This issue is also tracked as GHSL-2022-094.
NVD description
discordrb is an implementation of the Discord API using Ruby. In discordrb before commit `91e13043ffa` the `encoder.rb` file unsafely constructs a shell string using the file parameter, which can potentially leave clients of discordrb vulnerable to command injection. The library is not directly exploitable: the exploit requires that some client of the library calls the vulnerable method with user input. However, if unsafe input reaches the library method, then an attacker can execute arbitrary shell commands on the host machine. Full impact will depend on the permissions of the process running the `discordrb` library and will likely not be total system access. This issue has been addressed in code, but a new release of the `discordrb` gem has not been uploaded to rubygems. This issue is also tracked as `GHSL-2022-094`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free