In short
- CVE-2023-28118 is a HIGH (CVSS 7.5) vulnerability affecting com.charleskorn.kaml:kaml, kaml (kaml project).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 62.2% of all vulnerabilities.
- Fix: update to 0.53.0 or later.
Description
Impact
Applications that use kaml to parse untrusted input containing anchors and aliases may consume excessive memory and crash.
Patches
Version 0.53.0 and later default to refusing to parse YAML documents containing anchors and aliases.
Workarounds
None.
References
Wikipedia has an explanation of this class of vulnerability: billion laughs attack
Acknowledgements
Thank you to @gdude2002 for reporting this issue.
NVD description
kaml provides YAML support for kotlinx.serialization. Prior to version 0.53.0, applications that use kaml to parse untrusted input containing anchors and aliases may consume excessive memory and crash. Version 0.53.0 and later default to refusing to parse YAML documents containing anchors and aliases. There are no known workarounds.
More vulnerabilities in com.charleskorn.kaml:kaml
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free