In short
- CVE-2023-28154 is a CRITICAL (CVSS 9.8) vulnerability affecting webpack (webpack.js), webpack.
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.7% of all vulnerabilities.
- Fix: update to 5.76.0 or later.
| Package | Affected versions | Patched versions |
|---|
| webpack | ≥ 5.0.0, < 5.76.0
| 5.76.0
|
| webpack npm | ≥ 5.0.0, < 5.76.0
| 5.76.0
|
Description
Webpack 5 before 5.76.0 does not avoid cross-realm object access. ImportParserPlugin.js mishandles the magic comment feature. An attacker who controls a property of an untrusted object can obtain access to the real global object.
NVD description
Webpack 5 before 5.76.0 does not avoid cross-realm object access. ImportParserPlugin.js mishandles the magic comment feature. An attacker who controls a property of an untrusted object can obtain access to the real global object.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free