In short
- CVE-2023-28850 is a MEDIUM (CVSS 5.4) vulnerability affecting pimcore/perspective-editor, perspective editor (pimcore).
- Chance of exploitation in the next 30 days (EPSS): 0.57%, higher than 47.5% of all vulnerabilities.
- Fix: update to 1.5.1 or later.
Description
Impact
This vulnerability has the potential to steal a user's cookie and gain unauthorized access to that user's account through the stolen cookie or redirect users to other malicious sites.
Patches
Update to version 1.5.1.
Workarounds
Apply the patch https://github.com/pimcore/perspective-editor/pull/121.patch manually.
NVD description
Pimcore Perspective Editor provides an editor for Pimcore that allows users to add/remove/edit custom views and perspectives. This vulnerability has the potential to steal a user's cookie and gain unauthorized access to that user's account through the stolen cookie or redirect users to other malicious sites. Version 1.5.1 has a patch. As a workaround, one may apply the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free