In short
- CVE-2023-29216 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.linkis:linkis-datasource, linkis (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.9% of all vulnerabilities.
- Fix: update to 1.3.2 or later.
Description
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker can use the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Users should upgrade their version of Linkis to version 1.3.2.
NVD description
In Apache Linkis <=1.3.1, because the parameters are not
effectively filtered, the attacker uses the MySQL data source and malicious parameters to
configure a new data source to trigger a deserialization vulnerability, eventually leading to
remote code execution.
Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users upgrade the version of Linkis to version 1.3.2.
More vulnerabilities in org.apache.linkis:linkis-datasource
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free