In short
- CVE-2023-2968 is a HIGH (CVSS 7.5) vulnerability affecting proxy (proxy project), proxy.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.0% of all vulnerabilities.
- Fix: update to 2.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| proxy | ≥ 2.0.0, < 2.1.1
| 2.1.1
|
| proxy npm | ≥ 2.0.0, < 2.1.1
| 2.1.1
|
Description
A remote attacker can trigger a denial of service in the socket.remoteAddress variable, by sending a crafted HTTP request. Usage of the undefined variable raises a TypeError exception.
NVD description
A remote attacker can trigger a denial of service in the socket.remoteAddress variable, by sending a crafted HTTP request. Usage of the undefined variable raises a TypeError exception.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free