In short
- CVE-2023-30172 is a HIGH (CVSS 7.5) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.0% of all vulnerabilities.
- Fix: update to 2.0.0rc0, 2.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.0.0rc0< 2.0.1
| 2.0.0rc02.0.1
|
| mlflow | < 2.0.1
| 2.0.1
|
Description
A directory traversal vulnerability in the /get-artifact API method of the mlflow platform prior to v2.0.0 allows attackers to read arbitrary files on the server via the path parameter.
NVD description
A directory traversal vulnerability in the /get-artifact API method of the mlflow platform up to v2.0.1 allows attackers to read arbitrary files on the server via the path parameter.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free