In short
- CVE-2023-30363 is a CRITICAL (CVSS 9.8) vulnerability affecting vconsole (tencent), vconsole.
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 61.7% of all vulnerabilities.
- Fix: update to 3.15.1 or later.
| Package | Affected versions | Patched versions |
|---|
| vconsole | = 3.15.0
| No fix yet |
| vconsole npm | < 3.15.1
| 3.15.1
|
Description
vConsole was discovered to contain a prototype pollution due to incorrect key and value resolution in setOptions in core.ts.
NVD description
vConsole v3.15.0 was discovered to contain a prototype pollution due to incorrect key and value resolution in setOptions in core.ts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free