In short
- CVE-2023-30843 is a MEDIUM (CVSS 6.5) vulnerability affecting payload (payloadcms), payload.
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.2% of all vulnerabilities.
- Fix: update to 1.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| payload | < 1.7.0
| 1.7.0
|
| payload npm | < 1.7.0
| 1.7.0
|
Description
Details
If a user has access to documents that contain hidden fields or fields they do not have access to, the user could reverse-engineer those values via brute force.
Affected versions: < 1.7.0
Workarounds
If you are unable to update, you can write a beforeOperation hook to remove where queries that attempt to access hidden field data.
Detecting Compromise
Monitor your instance for brute-force style requests against your instance using where queries.
NVD description
Payload is a free and open source headless content management system. In versions prior to 1.7.0, if a user has access to documents that contain hidden fields or fields they do not have access to, the user could reverse-engineer those values via brute force. Version 1.7.0 contains a patch. As a workaround, write a `beforeOperation` hook to remove `where` queries that attempt to access hidden field data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free