In short
- CVE-2023-31543 is a CRITICAL (CVSS 9.8) vulnerability affecting pipreqs, pipreqs (pipreqs project).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.8% of all vulnerabilities.
- Fix: update to 0.4.12 or later.
| Package | Affected versions | Patched versions |
|---|
| pipreqs PyPI | ≥ 0.3.0, < 0.4.12
| 0.4.12
|
| pipreqs | ≥ 0.3.0, ≤ 0.4.11
| No fix yet |
Description
A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.
NVD description
A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free