In short
- CVE-2023-31606 is a HIGH (CVSS 7.5) vulnerability affecting RedCloth, redcloth (promptworks).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.6% of all vulnerabilities.
- Fix: update to 4.3.3 or later.
| Package | Affected versions | Patched versions |
|---|
| RedCloth RubyGems | < 4.3.3
| 4.3.3
|
| redcloth | ≥ 4.0.0, ≤ 4.3.2
| No fix yet |
Description
A Regular Expression Denial of Service (ReDoS) issue was discovered in the sanitize_html function of RedCloth gem. This vulnerability allows attackers to cause a Denial of Service (DoS) via supplying a crafted payload.
NVD description
A Regular Expression Denial of Service (ReDoS) issue was discovered in the sanitize_html function of redcloth gem v4.0.0. This vulnerability allows attackers to cause a Denial of Service (DoS) via supplying a crafted payload.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free