In short
- CVE-2023-32688 is a HIGH (CVSS 7.5) vulnerability affecting parse server push adapter (parseplatform), parse-server-push-adapter.
- Chance of exploitation in the next 30 days (EPSS): 0.90%, higher than 59.7% of all vulnerabilities.
- Fix: update to 4.1.3 or later.
Description
Impact
The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload.
Patches
Invalid push notification payload is caught and an logged.
Workarounds
n/a
References
NVD description
parse-server-push-adapter is the official Push Notification adapter for Parse Server. The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. This issue has been patched in version 4.1.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free