Apache RocketMQ Command Execution Vulnerability. Actively exploited: CISA added this vulnerability to its Known Exploited Vulnerabilities catalog on 06/09/2023. Patch affected systems as an emergency.
| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.rocketmq:rocketmq-broker | ≥ 5.0.0, < 5.1.1 | 5.1.1 |
| org.apache.rocketmq:rocketmq-controller | ≥ 5.0.0, < 5.1.1 | 5.1.1 |
| org.apache.rocketmq:rocketmq-namesrv | ≥ 4.0.0, < 4.9.6≥ 5.0.0, < 5.1.1 | 4.9.65.1.1 |
| rocketmq | ≥ 5.0.0, < 5.1.1< 4.9.6 | 5.1.14.9.6 |
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.
Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.
To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free