In short
- CVE-2023-34089 is a MEDIUM (CVSS 6.1) vulnerability affecting decidim, decidim-core, decidim (decidim).
- Chance of exploitation in the next 30 days (EPSS): 0.74%, higher than 54.5% of all vulnerabilities.
- Fix: update to 0.26.7, 0.27.3 or later.
| Package | Affected versions | Patched versions |
|---|
| decidim RubyGems | ≥ 0.14.0, < 0.26.7≥ 0.27.0, < 0.27.3
| 0.26.70.27.3
|
| decidim-core RubyGems | ≥ 0.14.0, < 0.26.7≥ 0.27.0, < 0.27.3
| 0.26.70.27.3
|
| decidim | ≥ 0.27.0, < 0.27.3< 0.26.7
| 0.27.30.26.7
|
Description
Impact
The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing.
Patches
The problem was patched in v0.27.3 and v0.26.7
NVD description
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free