In short
- CVE-2023-34110 is a LOW (CVSS 2.7) vulnerability affecting flask-appbuilder, flask-appbuilder (flask-appbuilder project).
- Chance of exploitation in the next 30 days (EPSS): 0.68%, higher than 52.3% of all vulnerabilities.
- Fix: update to 4.3.2 or later.
Description
Impact
An authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password.
Patches
Fixed on 4.3.2
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
More vulnerabilities in flask-appbuilder
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free