In short
- CVE-2023-34540 is a CRITICAL (CVSS 9.8) vulnerability affecting langchain, langchain (langchain).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.0% of all vulnerabilities.
- Fix: update to 0.0.225 or later.
| Package | Affected versions | Patched versions |
|---|
| langchain PyPI | < 0.0.225
| 0.0.225
|
| langchain | = 0.0.171
| No fix yet |
Description
Langchain before v0.0.225 was discovered to contain a remote code execution (RCE) vulnerability in the component JiraAPIWrapper (aka the JIRA API wrapper). This vulnerability allows attackers to execute arbitrary code via crafted input. As noted in the "releases/tag" reference, a fix is available.
NVD description
Langchain before v0.0.225 was discovered to contain a remote code execution (RCE) vulnerability in the component JiraAPIWrapper (aka the JIRA API wrapper). This vulnerability allows attackers to execute arbitrary code via crafted input. As noted in the "releases/tag" reference, a fix is available.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free