In short
- CVE-2023-3470 is a MEDIUM (CVSS 6.1) vulnerability affecting big-ip access policy manager (f5), big-ip advanced firewall manager (f5), big-ip advanced web application firewall (f5).
- Chance of exploitation in the next 30 days (EPSS): 0.18%, higher than 7.1% of all vulnerabilities.
- Fix: update to 13.1.4, 14.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| big-ip access policy manager | = 15.1.0≥ 13.1.0, < 13.1.4≥ 14.1.0, < 14.1.4
| 13.1.414.1.4
|
| big-ip advanced firewall manager | = 15.1.0≥ 13.1.0, < 13.1.4≥ 14.1.0, < 14.1.4
| 13.1.414.1.4
|
| big-ip advanced web application firewall | = 15.1.0≥ 13.1.0, < 13.1.4≥ 14.1.0, < 14.1.4
| 13.1.414.1.4
|
| big-ip analytics | = 15.1.0≥ 13.1.0, < 13.1.4≥ 14.1.0, < 14.1.4
| 13.1.414.1.4
|
| big-ip application acceleration manager | = 15.1.0≥ 13.1.0, < 13.1.4≥ 14.1.0, < 14.1.4
| 13.1.414.1.4
|
| big-ip application security manager | |
Description
Specific F5 BIG-IP platforms with Cavium Nitrox FIPS HSM cards generate a deterministic password for the Crypto User account. The predictable nature of the password allows an authenticated user with TMSH access to the BIG-IP system, or anyone with physical access to the FIPS HSM, the information required to generate the correct password. On vCMP systems, all Guests share the same deterministic password, allowing those with TMSH access on one Guest to access keys of a different Guest.
The following BIG-IP hardware platforms are affected: 10350v-F, i5820-DF, i7820-DF, i15820-DF, 5250v-F, 7200v-F, 10200v-F, 6900-F, 8900-F, 11000-F, and 11050-F.
The BIG-IP rSeries r5920-DF and r10920-DF are not affected, nor does the issue affect software FIPS implementations or network HSM configurations.
Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
More vulnerabilities in big-ip access policy manager
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free