In short
- CVE-2023-3597 is a MEDIUM (CVSS 5.0) vulnerability affecting org.keycloak:keycloak-services.
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 48.8% of all vulnerabilities.
- Fix: update to 24.0.3, 22.0.10 or later.
Description
Keycloak does not correctly validate its client step-up authentication. A password-authed attacker could use this flaw to register a false second auth factor, alongside the existing one, to a targeted account. The second factor then permits step-up authentication.
NVD description
A flaw was found in Keycloak, where it does not correctly validate its client step-up authentication in org.keycloak.authentication. This flaw allows a remote user authenticated with a password to register a false second authentication factor along with an existing one and bypass authentication.
More vulnerabilities in org.keycloak:keycloak-services
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free