In short
- CVE-2023-36189 is a HIGH (CVSS 7.5) vulnerability affecting langchain, langchain (langchain).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 69.3% of all vulnerabilities.
- Fix: update to 0.0.247 or later.
| Package | Affected versions | Patched versions |
|---|
| langchain PyPI | < 0.0.247
| 0.0.247
|
| langchain | = 0.0.64
| No fix yet |
Description
SQL injection vulnerability in langchain allows a remote attacker to obtain sensitive information via the SQLDatabaseChain component.
NVD description
SQL injection vulnerability in langchain before v0.0.247 allows a remote attacker to obtain sensitive information via the SQLDatabaseChain component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free