In short
- CVE-2023-36258 is a CRITICAL (CVSS 9.8) vulnerability affecting langchain, langchain (langchain).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.0% of all vulnerabilities.
- Fix: update to 0.0.247 or later.
| Package | Affected versions | Patched versions |
|---|
| langchain PyPI | < 0.0.247
| 0.0.247
|
| langchain | = 0.0.199
| No fix yet |
Description
An issue in langchain allows an attacker to execute arbitrary code via the PALChain in the python exec method.
NVD description
An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because Python code with os.system, exec, or eval can be used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free