In short
- CVE-2023-36475 is a CRITICAL (CVSS 9.8) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 3.2%, higher than 88.1% of all vulnerabilities.
- Fix: update to 6.2.1, 5.5.2 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 6.0.0, < 6.2.1< 5.5.2
| 6.2.15.5.2
|
| parse-server npm | ≥ 6.0.0, < 6.2.1< 5.5.2
| 6.2.15.5.2
|
Description
Impact
An attacker can use this prototype pollution sink to trigger a remote code execution through the MongoDB BSON parser.
Patches
Prevent prototype pollution in MongoDB database adapter.
Workarounds
Disable remote code execution through the MongoDB BSON parser.
Credits
- Discovered by hir0ot working with Trend Micro Zero Day Initiative
- Fixed by dbythy
- Reviewed by mtrezza
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 5.5.2 and 6.2.1, an attacker can use a prototype pollution sink to trigger a remote code execution through the MongoDB BSON parser. A patch is available in versions 5.5.2 and 6.2.1.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free