In short
- CVE-2023-37365 is a MEDIUM (CVSS 6.5) vulnerability affecting hnswlib, hnswlib (hnswlib project).
- Chance of exploitation in the next 30 days (EPSS): 0.59%, higher than 48.3% of all vulnerabilities.
- Fix: update to 0.8.0 or later.
| Package | Affected versions | Patched versions |
|---|
| hnswlib PyPI | < 0.8.0
| 0.8.0
|
| hnswlib | = 0.7.0
| No fix yet |
Description
Hnswlib 0.7.0 has a double free in init_index when the M argument is a large integer.
NVD description
Hnswlib 0.7.0 has a double free in init_index when the M argument is a large integer.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free