In short
- CVE-2023-38337 is a HIGH (CVSS 7.5) vulnerability affecting rswag, rswag (rswag project).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.0% of all vulnerabilities.
- Fix: update to 2.10.1 or later.
| Package | Affected versions | Patched versions |
|---|
| rswag RubyGems | < 2.10.1
| 2.10.1
|
| rswag | < 2.10.1
| 2.10.1
|
Description
rswag before 2.10.1 allows remote attackers to read arbitrary JSON and YAML files via directory traversal, because rswag-api can expose a file that is not the OpenAPI (or Swagger) specification file of a project.
NVD description
rswag before 2.10.1 allows remote attackers to read arbitrary JSON and YAML files via directory traversal, because rswag-api can expose a file that is not the OpenAPI (or Swagger) specification file of a project.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free