In short
- CVE-2023-38504 is a HIGH (CVSS 7.5) vulnerability affecting sails (sailsjs), sails.
- Chance of exploitation in the next 30 days (EPSS): 0.94%, higher than 61.0% of all vulnerabilities.
- Fix: update to 1.5.7 or later.
| Package | Affected versions | Patched versions |
|---|
| sails | < 1.5.7
| 1.5.7
|
| sails npm | < 1.5.7
| 1.5.7
|
Description
Impact
In Sails apps <=v1.5.6, an attacker can send a virtual request that will cause the node process to crash.
Patches
This behavior was fixed in Sails v1.5.7
Workarounds
Disable the sockets hook and remove the sails.io.js client
References
https://github.com/balderdashy/sails/pull/7287
Big thanks to @ThomasRinsma at Codean!
NVD description
Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free