In short
- CVE-2023-38691 is a MEDIUM (CVSS 6.5) vulnerability affecting matrix-appservice-bridge (matrix), matrix-appservice-bridge.
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.3% of all vulnerabilities.
- Fix: update to 8.1.2, 9.0.1 or later.
Description
Impact
A malicious Matrix server can use a foreign user's MXID in an OpenID exchange, allowing a bad actor to impersonate users when using the provisioning API.
Details
The library does not check that the servername part of the sub parameter (containing the user's claimed MXID) is the same as the servername we are talking to. A malicious actor could spin up a server on any given domain, respond with a sub parameter according to the user they want to act as and use the resulting token to perform provisioning requests.
Workarounds
Disable the provisioning API. If the bridge does not use the provisioning API, you are not vulnerable.
NVD description
matrix-appservice-bridge provides an API for setting up bridges. Starting in version 4.0.0 and prior to versions 8.1.2 and 9.0.1, a malicious Matrix server can use a foreign user's MXID in an OpenID exchange, allowing a bad actor to impersonate users when using the provisioning API. The library does not check that the servername part of the `sub` parameter (containing the user's *claimed* MXID) is the the same as the servername we are talking to. A malicious actor could spin up a server on any given domain, respond with a `sub` parameter according to the user they want to act as and use the resulting token to perform provisioning requests. Versions 8.1.2 and 9.0.1 contain a patch. As a workaround, disable the provisioning API.
More vulnerabilities in matrix-appservice-bridge
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free