In short
- CVE-2023-38860 is a CRITICAL (CVSS 9.8) vulnerability affecting langchain, langchain (langchain).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.8% of all vulnerabilities.
- Fix: update to 0.0.247 or later.
| Package | Affected versions | Patched versions |
|---|
| langchain PyPI | < 0.0.247
| 0.0.247
|
| langchain | = 0.0.231
| No fix yet |
Description
An issue in LangChain prior to v.0.0.247 allows a remote attacker to execute arbitrary code via the prompt parameter.
NVD description
An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free